読者です 読者をやめる 読者になる 読者になる

インストールする(その7)

Apache 2.0.54のアンインストール

coMomongaに既にインストールされているApache 2.0.54が正常に動作しない。
最初は起動していたが、何度もstartとstopを繰り返すと、何回目かで正常に起動せず、初期化処理で止まってしまうようだ。
また、mod_perl 1.99は最初から正常に動作せず、PerlHanderの初期化でエラーが発生する。
ホストを変えて見るなど、色々と試したが、どうしても駄目だった。
悩んでいても仕方がないので、Apache 2.0.54はアンインストールすることにした。

# rpm -e httpd-2.0.54-2m
error: Failed dependencies:
        httpd >= 2.0.53 is needed by (installed) php-5.0.4-9m
# rpm -e php-5.0.4-9m
error: Failed dependencies:
        php >= 4.1.0 is needed by (installed) doxygen-1.3.9.1-1m
# rpm -e doxygen-1.3.9.1-1m
# rpm -e php-5.0.4-9m
# rpm -e httpd-2.0.54-2m
warning: /etc/httpd/conf/httpd.conf saved as /etc/httpd/conf/httpd.conf.rpmsave

そのうちにApacheをソースからビルドしてインストールして見ようと思う。