読者です 読者をやめる 読者になる 読者になる

PDKを購入した

訳があってPDK (Perl Dev Kit) 7.0 Deployment Toolsを購入した。
キャンペーン期間中とは言えUS$115(約14000円)もしたのだが、残念なことに以下のエラーが発生しインストールに失敗してしまった。

【最初から発生するエラー】
An error occurred during the installation of assembly
'PerlRT70.dll,Version="7.0.0.14914"'.
Please refer to Help and Support for more information.
HRESULT: 0x8002802F.
【2回目から発生するエラー】
Internal Error 2908.
{3842EC86-6EA5-4034-B988-8B9031436A39}


ActiveStateのカスタマーサポートにメールして見たところ、「それならFAQに載ってるよ。詳しくは以下のURLを見てくれ。(英語なのでそう言っているように感じる)」とあっけらからんとした返答が戻ってきた。

http://support.activestate.com/faq/error-2908-problems-insta

結局はMicrosoft .NET Framework 2.0が必要だったらしい。
インストールされていることが当然なのかどうかは分からないが、一言ダウンロードページに書いてあれば回答する手間が減ると思う。
また、会社の尊厳を損なわないで済むはずである。
実際に私は、無償で素晴らしいスクリプト言語環境を世界中に発信している会社を尊敬していたのだが、今回の件で少しだけ信頼度が下がってしまった。
大変残念なことである。